Вибрации квадрика на раме Q330 (настройка гейнов)

Автор: HOBBY-FLY. Опубликовано в Видео канал

Рейтинг:  0 / 5

Звезда не активнаЗвезда не активнаЗвезда не активнаЗвезда не активнаЗвезда не активна
 
Мой новый проект "МУХА" - это квадрокоптер на китайской раме LJI Totem Q330 с ассиметричными лучами. Используемый полетный контроллер Tarot ZYX-M. Более подробно о конфигурации чуть позже, в основном использовал имеющееся у меня барахло.. ну и кое что пришлось докупить...


Возможно ошибка в настройке гейнов (gain) Tarot ZYX-M рама LJI Totem Q330. Гейны были выставлены в соответствии с рекомендациями Tarot для рамы X330: Basic Gains: Pitch 20, Roll 20, Pan 50 Vertical 25 Attitude Gains: Pitch 20, Roll 20, Vertical 50

Tags: Tarot ZYX-M ZYX-M LJI Totem Q330 вибрация настройка гейнов

Комментарии  

0 #2 HobbyFly 27.11.2017 20:59
Итак, проблема найдена и устранена! Дело было в дефектных 8-ми дюймовых карбоновых пропах, что шли в комплекте двигателями... Заменены на трехлопастные 7-ми дюймовые, гейны выставлены по умолчанию, как для 550 рамы... и все ок.
Цитировать
0 #1 HobbyFly 12.10.2017 14:32
Нефига это не гейны (вероятней всего)... Вот что я сделал: изменил гейны, установив значения по-умолчанию - Basic Gains: Pitch 30, Roll 30, Pan 60 Vertical 30; Attitude Gains: Pitch 20, Roll 20, Vertical 50 (как для 450 рамы), заново откалибровал акселерометр и гироскоп, внес поправки в расположение модуля GPS относительно центра рамы - результат нулевой.
Вибрация модели в полете осталась прежней.... Даже не знаю на что и подумать... Есть правда один момент: при сборке квадрика допустил классический косяк, когда паял силовой разъем XT60 напутал с полярностью проводов... в результате после первой подачи питания от батареи спалил нафиг (до дыма) PMU. Заменил PMU на новое, надеясь что больше ничего не задело... возможно я оказался не прав.
Напрягает еще тот факт , что теперь не могу откалибровать компас (до того как сжег PMU - все калибровалось "ок"). При процедуре калибровки компаса нет нормальной индикации: "синий - зеленый - зеленый гаснет". Т.е. в режим калибровки компаса контроллер входит нормально (горит синий). Вращаю горизонтально - зеленый не загорается, а как-то слабенько промаргивает. Вращаю вертикально LED не светится, затем просто начинает мигать фиолетовым (GPS mode). Так что делаю вывод, что компас не калибруется...
Еще одна возможная причина вибрации - несбалансированные пропы... или моторы
Ну и самое худшее - сам контроллер...
В общем что решил:
1. Попробую отбалансировать пропы...
2. Отбалансировать моторы
3. Попробую перепрошить и заново откалибровать контроллер

Может кто сталкивался с такой проблемой? Коллеги помогите!
Цитировать

Добавить комментарий


Защитный код
Обновить